Lag and glitching when running Deus Ex

A refuge for those migrating from the fallen DXEditing.com and a place for general discussion relating to Deus Ex editing (coding, mapping, etc).
Post Reply
Morpheus
X-51
Posts: 967
Joined: Thu Jan 27, 2005 9:56 am
Location: A planet near mars

Lag and glitching when running Deus Ex

Post by Morpheus »

I recently upgraded my PC with a new Motherboard, Intel Core i7 7700K 4Ghz, 32GB RAM, Geforce 970GTX and Windows 10. Before that I was running Windows 7 and Deus Ex worked fine then. I decided to play Deus Ex again as I wanted to play Hotel Carone mod. I am running Kenties Launcher. I have tried Direct 3D, D3D9, D3D10 and a D3D11 renders and still get the same issues. So I run Hotel Carone via Kenties launcher. Wanted to see the black bars on cinematic so I could see the text. I set the resolution to 1440x900. This seems like a graphical problem.

When the menu map loads, the map interpolation works fine but there is some slight glitches and clipping on Actors like Decorations, NPCs etc... and when I load the main menu, the game gets very laggy and slows to near a crawl. Does anyone know how to fix this? Also the 1440x900 16:9 resolution I set, doesn't fix the black bars with text not appearing on intro map.
My nature videos: http://www.youtube.com/user/DynamixWarePro
My whistle/flute videos (and some other videos): http://www.youtube.com/user/DXMorpheus
Morpheus
X-51
Posts: 967
Joined: Thu Jan 27, 2005 9:56 am
Location: A planet near mars

Re: Lag and glitching when running Deus Ex

Post by Morpheus »

Nevermind fixed it, been ages since I played DeusEx and forgot to change some settings in the ini file.
My nature videos: http://www.youtube.com/user/DynamixWarePro
My whistle/flute videos (and some other videos): http://www.youtube.com/user/DXMorpheus
Post Reply